This project is read-only.

Blueprint Package?

Jan 7, 2011 at 5:54 PM

I see the Blueprint package in the packages list, but I can't figure out the package name. All the variations I've tried either come up with "Unable to find" or "invalid project name". Any thoughts?

Jan 7, 2011 at 6:08 PM

Not following you.  Can you describe exactly what you are trying, and what you are seeing?

Jan 7, 2011 at 6:12 PM

In package manager console, when trying to install the Blueprint CSS library:

install-package blueprint (results in not found)
install-package blueprintcss (results in not found)
install-package blueprint css (results in invalid proj. name due to space presumably)
install-package blueprint-css (results in not found)
install-package blueprint.css (results in not found)

When I run get-package -remote (with or without a filter on "blueprint") the Blueprint CSS package is listed as available.  The name listed is "Blueprint CSS", but no indication of what to use when referencing the package in the install-package command.

Jan 7, 2011 at 6:14 PM

Try:

Install-Package 'Blueprint CSS'

Note that you get intellisense, so just type bl and TAB.

Jan 7, 2011 at 6:16 PM

Super useful. Thanks so much!

Jan 7, 2011 at 7:21 PM

Something to add as a best practice: don't use spaces in your package names.

Possible, just not a good practice.

____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Jan 7, 2011 at 7:23 PM

Yes, this has come up before, and it would be best not to do that.  We should just make it illegal.  I think there are just a couple right now.

Jan 7, 2011 at 7:27 PM

Any reason not allowing it would be a bad idea?

I can't think of any myself.

____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Jan 7, 2011 at 7:31 PM

(I'm not a contributer but) As a consumer, it makes sense to me.

Jan 7, 2011 at 7:42 PM

Filed http://nuget.codeplex.com/workitem/543